紫猫学院社区

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 50|回复: 1

[已回复] ini读写配置插件怎么与易语言的写配置项配合使用

[复制链接]

2

主题

2

帖子

2

积分

学前班

Rank: 1

猫粮
6
发表于 2019-5-10 11:07:42 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x

紫猫哥:

ini读写插件默认配置文件是UTF-8格式


易语言读写配置文件是ANSI格式,但是经编码转换后,还是读不到UTF-8的配置文件,不知道怎么回事


[mw_shl_code=qscript,true].版本 2
.支持库 spec

.局部变量 配置文件路径, 文本型

配置文件路径 = 取运行目录 () + “\Config.ini”

调试输出 (读配置项Utf8 (配置文件路径, “账号配置”, “进度1”, ))

.版本 2
.支持库 spec

.局部变量 配置文件路径, 文本型

配置文件路径 = 取运行目录 () + “\Config.ini”

调试输出 (读配置项Utf8 (配置文件路径, “账号配置”, “进度1”, ))


.子程序 读配置项Utf8, 文本型, 公开, 读写UTF-8配置项文件
.参数 配置项文件名, 文本型
.参数 节点名称, 文本型
.参数 配置项名称, 文本型
.参数 默认文本, 文本型, 可空
.局部变量 str, 文本型

返回 (编码_utf8到gb2312 (读配置项 (配置项文件名, 到文本 (编码_Ansi到Utf8 (节点名称)), 到文本 (编码_Ansi到Utf8 (配置项名称)), 到文本 (编码_Ansi到Utf8 (默认文本)))))


回复

使用道具 举报

271

主题

1037

帖子

1037

积分

院长

Rank: 9Rank: 9Rank: 9

猫粮
1882
QQ
发表于 2019-5-11 11:47:11 | 显示全部楼层
应该是你易语言代码问题
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|紫猫编程学院  

GMT+8, 2019-5-25 09:55

Powered by Discuz! X3.4

© 2012-2018 紫猫编程学院

快速回复 返回顶部 返回列表