紫猫学院社区

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 186|回复: 3

[教程源码] 简歌 短信验证平台(思路)

[复制链接]

13

主题

72

帖子

72

积分

按键电脑&手机班学员

Rank: 8Rank: 8

猫粮
234
QQ
发表于 2019-9-25 19:05:10 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
先说几句题外话:
离开也有一段时间了
突然有时间回来看看
新帖都特么什么水平 实在忍不住 搞点干货吧

实在搞不懂 225654155(直接找我)

为什么是思路?
如今我已经不主要从事定制了 没必要为了点热度发我的新作品 要也行(明码标价 直接找我)

随着短信平台一个个都死了 估计以后也活不了了 所以我就心血来潮做了一个
没想到 日销量20 可以可以

首先 自制平台就肯定需要 服务器 猫池(卡池)

然后我意外的发现了一个可以直接把酷卡软件接进QQ的软件
enmmm 好吧
传送门 http://www.fafa986.com/(这特么不是广告后面要用 而且便宜)
既然可以发到QQ那么灵机一动 酷q机器人可以把QQ里的内容传到服务器

这样一来 手机号导入手机 然后点接短信 然后在通过机器人发送到服务器 在然后通过get post获取服务器内容不就搞定了?
具体的自己想(我高冷)

下面附送酷q机器人发送内容到服务器代码 送给认真看完的你

//易语言代码

[按键精灵] 纯文本查看 复制代码
.版本 2
.支持库 RegEx
.支持库 spec
.支持库 internet

.局部变量 分割, 文本型, , "0"
.局部变量 手机号, 文本型
.局部变量 短信, 文本型
.局部变量 短信2, 文本型
.局部变量 正则, 正则表达式
.局部变量 a, 搜索结果, , "0"
.局部变量 寻找, 整数型
.局部变量 寻找2, 整数型
.局部变量 寻找3, 整数型

' 本子程序会在酷Q【线程】中被调用,请注意使用对象等需要初始化(CoInitialize,CoUninitialize)。
' CQ.发送私聊消息 (fromQQ, 到文本 (fromQQ))
寻找 = 寻找文本 (msg, “一网通”, 1, 假)
寻找2 = 寻找文本 (msg, “您已开通招商银行”, 1, 假)
寻找3 = 寻找文本 (msg, “您已成功注册一网通”, 1, 假)
.判断开始 (寻找 = -1)
    CQ.发送私聊消息 (fromQQ, “自动屏蔽非一网通短信”)

.默认

    .判断开始 (寻找2 = -1)
        .判断开始 (寻找3 = -1)
            分割 = 分割文本 (到文本 (msg), “ ”, )
            手机号 = 分割 [2]
            短信 = 分割 [3]
            正则.创建 (“\d{6}”, 真)
            a = 正则.搜索全部 (短信)
            短信2 = a [1].取匹配文本 (短信, )
            调试输出 (短信2)

            HTTP读文件 (“[url]http://12.123.123/api/index/add?name=[/url]” + 手机号 + “&pwd=” + 短信2)
            CQ.发送私聊消息 (fromQQ, “接收成功”)
            CQ.发送私聊消息 (fromQQ, 手机号)
            CQ.发送私聊消息 (fromQQ, 短信2)

        .默认

            CQ.发送私聊消息 (fromQQ, “已排除多余一卡通短信”)
        .判断结束

    .默认

        CQ.发送私聊消息 (3250772785, msg)
        CQ.发送私聊消息 (fromQQ, “开通成功”)
    .判断结束

.判断结束

' 如果要回复消息,请调用 api 发送,则 返回(#消息_拦截) - 拦截本条消息,不再由其他继续处理 //注意:应用优先级设置为"最高"(10000)时,无法使用本返回值
' 如果不回复消息,交由之后的应用处理,则 返回(#消息_忽略) - 忽略本条消息
返回 (#消息_忽略)

简歌 专业定制 安卓按键 易语言 lua插件 各类验证码本地 语音内录 语音替换
回复

使用道具 举报

13

主题

72

帖子

72

积分

按键电脑&手机班学员

Rank: 8Rank: 8

猫粮
234
QQ
 楼主| 发表于 2019-9-25 19:23:19 | 显示全部楼层
老规矩 沙发自己做
简歌 专业定制 安卓按键 易语言 lua插件 各类验证码本地 语音内录 语音替换
回复

使用道具 举报

0

主题

4

帖子

4

积分

按键电脑&手机班学员

Rank: 8Rank: 8

猫粮
34
发表于 2019-9-26 07:30:07 | 显示全部楼层
膜拜大神
回复

使用道具 举报

0

主题

3

帖子

3

积分

学前班

Rank: 1

猫粮
5
发表于 2019-10-7 13:05:51 | 显示全部楼层
大神,你的这个想法是可以的。但是估计扛不住商业的运作量级,而且操作也特麻烦,不能用做于商业应用吧?
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|紫猫编程学院  

GMT+8, 2019-10-16 23:06

Powered by Discuz! X3.4

© 2012-2018 紫猫编程学院

快速回复 返回顶部 返回列表